Release of MyBudgetFile Budget Planning Version 26.1
Resolved
Jan 22, 2026 at 08:45am UTC
The deployment of version 26.1 has completed. Release notes for the new version will be sent to you on Thursday, January 22 describing the new features.
Affected services
Updated
Jan 22, 2026 at 06:00am UTC
The deployment of MyBudgetFile Budget Planning v26.1 is still on-going. While disruption to the existing version of the application has not occurred, users may still experience some inability to access the site as the reconfiguration continues. We will update you again when the process has finished. Current estimated time of completion is 12:00 AM, Thursday, January 22 (1 more hour).
Affected services
Created
Jan 22, 2026 at 04:00am UTC
MyBudgetFile Budget Planning v25.2 will be offline for periods of time between 9:00 PM and 11:00 PM Mountain Standard Time on Wednesday, January 21 to facilitate the deployment of v26.1.
Check back here occasionally during that timeframe to see status updates and the outcome of the maintenance work. Users will receive a separate email containing release notes if the maintenance work goes according to plans.
Affected services