Back to overview
Downtime

MyBudgetFile Budget Planning App Inaccessible

Oct 29 at 10:09am MDT
Affected services
Sign-In Page
Version 23.2
Budget Planning App Version 25.1

Resolved
Nov 05 at 03:58pm MST

No further sign-in problems have been reported by users in the last two days. We believe we have successfully restored services that are still bypassing Microsoft's affected systems from last week's outage.

Updated
Oct 31 at 03:53pm MDT

It has been a spooky day at the office! As Microsoft continues to work to restore their services, MyBudgetFile sign-in capability this afternoon has been up and down. We have just deployed further changes to continue to try to work around the problem while the very nature of the problem continues to change. We believe that services should be available to the majority, if not all, users now.

We understand your frustrations about this situation over the past couple of days, and we share them. We will continue to monitor Microsoft's updates and respond accordingly to effect a full resolution to the problem as quickly as possible.

Updated
Oct 31 at 01:31pm MDT

The vast majority of MyBudgetFile users are not having any problems accessing the sign-in page and using the budget planning application, but we continue to receive isolated reports from users of AADB2C90047 errors with the description "The resource '<url>' contains script errors preventing it from being loaded."

There are, indeed, no script errors. Our case by case analysis of this problem with affected users has suggested some anomaly in accessing the files necessary to display the sign-in page. We continue to investigate whether this relates to Microsoft's original underlying problem on Wednesday or if a different problem exists.

Updated
Oct 29 at 12:21pm MDT

Our staff has reconfigured MyBudgetFile to bypass the affected Microsoft Azure services. Users should have full functionality of the MyBudgetFile budget planning app again. One important thing to note about our temporary configuration is that the URL to which users are redirected for sign-in now begins with "mbfapp.b2clogin.com" rather than "id.app.mybudgetfile.com". This is legitimate, but we thought it was worth mentioning because some users might be concerned about phishing attempts.

We don't anticipate any downtime to revert to our typical configuration once Microsoft's services have been restored. Nonetheless, we will advise you again once services have been reconfigured.

Updated
Oct 29 at 11:28am MDT

Microsoft has confirmed that they are experiencing issues with Azure Front Door, the CDN and web application firewall that sits in front of MyBudgetFile. Their latest information suggests that they have identified what they believe to be an issue and they are in the process of rolling back an inadvertent configuration error. They have given no estimated time of resolution. For information directly from Microsoft, visit https://azure.status.microsoft/en-us/status. We will continue to update affected users here.

Created
Oct 29 at 10:09am MDT

Problems with underlying Microsoft Azure infrastructure are preventing users from accessing MyBudgetFile.